System requirements

  • Windows Vista, Windows 7, Windows 8, Windows 10
  • Windows Server 2008, Windows Server 2008 R2, Windows Server 2012, Windows Server 2012 R2, Windows Server 2016
  • Linux using Wine. Instructions for Linux
  • .Net Framework 4.5 or higher

If you don’t have .Net Framework 4.5 or higher you can download it from Microsoft web site

Messaging system requirements

MSMQ

  • Installed and running Message Queueing service on computer where QueueExplorer runs
  • MSMQ is shipped with Windows. If it’s not already installed go to: Add or Remove programs - Add/Remove Windows Components - Message Queuing

Windows 8 and Windows 2012 can cause blue screen on some configurations when accessing remote queues. It is MSMQ issue but affects QueueExplorer users as well. More details and hotfix: http://support.microsoft.com/kb/2840622

Azure Service Bus

  • Azure Service Bus, Basic/Standard/Premium tier
  • Not supported: Service Bus for Windows Server (Service Bus 1.1)

ActiveMQ

  • ActiveMQ broker installed on Unix/Linux/Windows
  • ActiveMQ 5.8 or higher.
  • Enabled Rest (Jolokia) management interface. This is turned on by default with newer ActiveMQ releases. Default port: 8161.
  • Enabled Openwire protocol (standard ActiveMQ messaging protocol enabled by default). Default port: 61616.

RabbitMQ